welcome on statuspage Oneshop

[EE] Checkout instabilities

Major incident I order products Europe Estonia
2025-04-15 07:00 CEST · 9 hours, 3 minutes

Updates

Post-mortem

Status

The incident is fully resolved.

Hello,
Following the incident experienced on April 15th , we share with you the related post mortem, with the action plans identified by our technical teams that should ensure we will not experience this incident again.

Sorry for the inconvenience

Description & root cause

User Impact : Customers experienced latency during checkout. Access to the Esto API was taking several minutes.
Root Cause : Server Maintenance on ESTO side

Incident duration : 7:27AM CET - 8:27AM CET

Post Mortem

Post Mortem 2317
Title: [2025-04-15] - [EE] - SLI Latency on Checkout
Link:https://decathlon.atlassian.net/wiki/spaces/XCOM/pages/1417183413/2025-04-15+-+EE+-+SLI+Latency+on+Checkout

Have a nice day!
OneShop Ecommerce Support contact

April 18, 2025 · 15:58 CEST
Resolved

Status

The issue is fully resolved.

Actions performed

As previously communicated, the latencies were caused by Esto. While we investigate the root cause, we temporarily disabled this payment method.
The Esto support team informed us that they had a maintenance operation this morning, which led to the observed latencies.
The incident has now been resolved, and we have reactivated the payment method.

Next communication

We will provide an incident report when the full analysis is completed.

OneShop Ecommerce Support contact

April 15, 2025 · 15:59 CEST
Update

Actions performed

ESTO is now available

April 15, 2025 · 15:54 CEST
Update

Actions performed

We received confirmation from the ESTO technical team that there was server maintenance this morning from 7:56 to 8:26.
Everything is now back to normal. We’ve requested to be notified about any future maintenance.
Reactivation of ESTO is in progress.

April 15, 2025 · 15:35 CEST
Issue

Actions in progress

Some checks are in progress on ESTO’s technical team side.
After further analysis, it looks like the API was unavailable only for a short period of time.
We’re currently waiting for ESTO’s feedback before considering reactivating ESTO.

April 15, 2025 · 14:05 CEST
Update

Actions in progress

Email sent to ESTO regarding the disruptions that occurred this morning.

April 15, 2025 · 10:08 CEST
Update

Actions in progress

The ESTO module has been disabled. We’ve contacted our technical contact on the ESTO side to get more information about the disruptions.

April 15, 2025 · 09:45 CEST
Update

While we wait for feedback from ESTO regarding the instabilities on their side, we will temporarily disable the ESTO module to avoid any impact on the user experience.

We’ll get back to you as soon as the situation is clarified or if any further action is needed.

April 15, 2025 · 09:10 CEST
Update

Impacts changes

Issue is not coming from OneShop but from one of our payment provider (Esto)

Actions in progress

Duty is handle the ball to Lower Funnel team to let them investigate with Esto what’s happened and how they can work all together to fix the issue

Estimated time of fix deployment

No estimations at the moment

Next communication

10:00 AM CET or before if we have news to share

OneShop Ecommerce Support contact

April 15, 2025 · 07:58 CEST
Issue

Hello,

An incident has been detected and we’re working on its resolution.
Sorry for the inconvenience.

Description

Checkout is facing instabilities since 07:00 am CET with unavailabilities and latencies.

Impacts

Customers may not be able to order products on our website.

Actions in progress

Analysis in progress

Estimated time of fix deployment

No estimations at the moment

Next communication

08:30 AM CET or before if we have news to share

OneShop Ecommerce Support contact

April 15, 2025 · 07:43 CEST

← Back